1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Issue with D5 top and pump

Discussion in 'SC Product Support' started by Mark Lira, Oct 2, 2017.

  1. Mark Lira

    Mark Lira New Member

    Hey guys,

    I have a problem with my Protium D5 top and Mainframe Customs M7 PWM pump I purchased. Basically they do not make a seal when I put them together.

    I put them together and screwed on my Protium D5 Cover and when I added water to the reservoir the pump/top/cover instantly started leaking. I disassembled the 3 to inspect them. What I found is that the pump and top cannot seal to each other.

    There is an o-ring in the top but the pump doesnt make contact with it. The pump itself has like a ring around the body and this touches the D5 top area where the threads are. Because of this the pump cannot make contact with the o-ring inside the D5 Top.

    Did I receive the correct D5 Top for my pump? It seems if the height of the threads on the D5 Top were just a little shorter the face of the pump would make contact with the o-ring inside the Top.

    I can take a picture and post if that helps.
     
  2. Febby

    Febby Administrator Staff Member

    Hi @Mark Lira, Thanks for purchasing our products and contacting us.

    The M7 pump has different dimensions to a normal D5. The only way to get it to work with any D5 pump top is with two o-rings.

    let me know if you have any more questions.
     

Share This Page